Basecamp 2 Help > Account & Billing > Browser Requirements

Browser Requirements

Basecamp 2 is built on the nifty features found in modern browsers. You'll need to use one of the browsers below to use Basecamp 2:

Picking a browser Internet Explorer 9+

Google Chrome - latest version

Mozilla Firefox - latest version

Apple Safari 5+

Apple iOS 8

Android Version 4

Basecamp 2 may not work properly with beta or pre-release versions of these browsers. Download the latest commercial version above for the best experience.


Still stuck? We'll call you.

Enter your phone number and we’ll call you within 30 minutes.

Thanks! We'll be in touch.

We'll give you a call as soon as we can. In most cases you'll receive a call from us within a few minutes.